Solved Solved

problem in adding ‘OAuth 2 Web Server Flow’ to the current revision.

Not applicable

I'm trying to add oAuth 2 web server flow to the smartDos model but getting below exception

"There was a problem adding ‘OAuth 2 Web Server Flow’ to the current revision"

278-oauth2flowexception.png

Could you please help in this, If you have any example or demo link please share.

Solved Solved
1 2 464
1 ACCEPTED SOLUTION
Solved Solved

Not applicable

From the message I guess it is actually the Custom Token which is causing the issue. When you add a custom token you need to specify what format the custom token is, for example a header value with the name api_key or a query string.

View solution in original post

Solved Solved
1 1 0
2 REPLIES 2
Solved Solved

Not applicable

From the message I guess it is actually the Custom Token which is causing the issue. When you add a custom token you need to specify what format the custom token is, for example a header value with the name api_key or a query string.

View solution in original post

Solved Solved
1 1 1

Not applicable

We were able to add the settings for oAuth 2.0 Web Server Flow. Bt still we are facing some issue.

1. The second request call for getting access token it's method type by default is GET. Is it possible to change it?

2. Is there any way to add headers and query parameters to this token generation request.

3. Is there a way to set callback URL for oAuth 2.0 Web Server Flow?

0 0 0
Top Labels in this Space
Top Solution Authors